Service Disruption
Incident Report for LanSchool Air
Resolved
This incident has been resolved.
Posted Dec 02, 2020 - 16:16 EST
Investigating
We are currently investigating an issue causing some customers to experience slow login times and missing classes. Thank you for your patience as we work to resolve this issue as quickly as possible.
Posted Dec 02, 2020 - 13:14 EST
This incident affected: Premier (Login and Authentication).